package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{13}\\n`)
var str = `
5038614652\n
9202032561428\n
^[0-9]{13}
^[0-9]{10,}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}