const regex = /^[0-9]{13}\\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{13}\\\\n', 'gm')
const str = `
5038614652\\n
9202032561428\\n
^[0-9]{13}
^[0-9]{10,}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}