use strict;
my $str = 'Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine
Butler Nephew’s 20 Years Old Port Wine
';
my $regex = qr/(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)/mp;
my $subst = ' $1 Years ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";