import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\\s|$)";
final String string = "Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine\n"
+ "Butler Nephew’s 20 Years Old Port Wine\n";
final String subst = " $1 Years ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}