# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)/ $1 Years /gm;t' <<< "Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine
Butler Nephew’s 20 Years Old Port Wine
"