use strict;
my $str = 'Hunou marque
Max marque un but à la 4ème
ki marque un doublé à la 45ème minute
Hunou marque triplé';
my $regex = qr/((marque)\s?(un)?\s?(but|doublé|triplé)?\s?(à)?\s?(la)?\s?[0-9]?[0-9]?(ème)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}