import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((marque)\\s?(un)?\\s?(but|doublé|triplé)?\\s?(à)?\\s?(la)?\\s?[0-9]?[0-9]?(ème)?)";
final String string = "Hunou marque\n"
+ "Max marque un but à la 4ème\n"
+ "ki marque un doublé à la 45ème minute\n"
+ "Hunou marque triplé";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}