using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((marque)\s?(un)?\s?(but|doublé|triplé)?\s?(à)?\s?(la)?\s?[0-9]?[0-9]?(ème)?)";
string input = @"Hunou marque
Max marque un but à la 4ème
ki marque un doublé à la 45ème minute
Hunou marque triplé";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}