import Foundation
let pattern = #"(?:https?:)?(?:\/\/)?(?:[0-9A-Z-]+\.)?(?:youtu\.be\/|youtube(?:-nocookie)?\.com\/\S*?[^\w\s-])((?!videoseries)[\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['"][^<>]*>|<\/a>))[?=&+%\w.-]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<p>asdad youtube
</p><div><br />
youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU
https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6
https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM
</div>
<div>daadsads</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://youtu.be/j2uN5Jeblf4</div>
https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)