use strict;
my $str = '<p>asdad youtube
</p><div><br />
youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU
https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6
https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM
</div>
<div>daadsads</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://youtu.be/j2uN5Jeblf4</div>
https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0';
my $regex = qr/(?:https?:)?(?:\/\/)?(?:[0-9A-Z-]+\.)?(?:youtu\.be\/|youtube(?:-nocookie)?\.com\/\S*?[^\w\s-])((?!videoseries)[\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['"][^<>]*>|<\/a>))[?=&+%\w.-]*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}