re = /(?:https?:)?(?:\/\/)?(?:[0-9A-Z-]+\.)?(?:youtu\.be\/|youtube(?:-nocookie)?\.com\/\S*?[^\w\s-])((?!videoseries)[\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['"][^<>]*>|<\/a>))[?=&+%\w.-]*/im
str = '<p>asdad youtube
</p><div><br />
youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU
https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6
https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM
</div>
<div>daadsads</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://youtu.be/j2uN5Jeblf4</div>
https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end