import Foundation
let pattern = #"^(?=\S*[a-z])(?=\S*[A-Z])(?=\S*[0-9])(?=\S*[[:punct:]|§µ¤£¨])\S{8,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaaAAA1!
aaaAA1!
aaaAA1!
aaaAAA1!
aaaAAA11
aaa1111!
aaA AA1111!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)