$re = '/^(?=\S*[a-z])(?=\S*[A-Z])(?=\S*[0-9])(?=\S*[[:punct:]|§µ¤£¨])\S{8,}$/m';
$str = 'aaaAAA1!
aaaAA1!
aaaAA1!
aaaAAA1!
aaaAAA11
aaa1111!
aaA AA1111!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);