#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\S*[a-z])(?=\S*[A-Z])(?=\S*[0-9])(?=\S*[[:punct:]|§µ¤£¨])\S{8,}$"
Local $sString = "aaaAAA1!" & @CRLF & _
"aaaAA1!" & @CRLF & _
"aaaAA1! " & @CRLF & _
" aaaAAA1!" & @CRLF & _
"aaaAAA11" & @CRLF & _
"aaa1111!" & @CRLF & _
"aaA AA1111!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")