import Foundation
let pattern = #"^\/(healthyawards)\/??$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://localhost:7003/u/global/gadgets/healthyAwardsClub.jsp
http://localhost:7003/healthyawards
http://localhost:7003/healthyawards/
http://localhost:7003/u/global/gadgets/healthyawards/healthyAwardsClub.jsp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)