#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\/(healthyawards)\/??$"
Local $sString = "http://localhost:7003/u/global/gadgets/healthyAwardsClub.jsp" & @CRLF & _
"http://localhost:7003/healthyawards" & @CRLF & _
"http://localhost:7003/healthyawards/" & @CRLF & _
"http://localhost:7003/u/global/gadgets/healthyawards/healthyAwardsClub.jsp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")