$re = '/^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\d{13})_(?<fldrComponentPrimaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<fldrComponentSecondaryId>tcx\d{0,3})(?:_r(?<fldrRevisionNumber>\d+))? Folder\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$/m';
$str = 'Obam_9781524763138_all_tcx_r3 Folder/Links/apple.pdf
Obam_9781524763138_all_tcx1_r3 Folder/Links/apple_r1.pdf
Obam_9781524763138_all_tcx10_r3 Folder/Links/001_apple_r1.pdf
Obam_9781524763138_all_tcx999_r3 Folder/Links/001_apple.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);