import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\\d{13})_(?<fldrComponentPrimaryId>all|tx\\d{0,3}|lay\\d{0,3}|c0\\d{1,3}|c[^0]\\d{1,2}?)_(?<fldrComponentSecondaryId>tcx\\d{0,3})(?:_r(?<fldrRevisionNumber>\\d+))? Folder\\/Links\\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$";
final String string = "Obam_9781524763138_all_tcx_r3 Folder/Links/apple.pdf\n"
+ "Obam_9781524763138_all_tcx1_r3 Folder/Links/apple_r1.pdf\n"
+ "Obam_9781524763138_all_tcx10_r3 Folder/Links/001_apple_r1.pdf\n"
+ "Obam_9781524763138_all_tcx999_r3 Folder/Links/001_apple.pdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}