#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\d{13})_(?<fldrComponentPrimaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<fldrComponentSecondaryId>tcx\d{0,3})(?:_r(?<fldrRevisionNumber>\d+))? Folder\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$"
Local $sString = "Obam_9781524763138_all_tcx_r3 Folder/Links/apple.pdf" & @CRLF & _
"Obam_9781524763138_all_tcx1_r3 Folder/Links/apple_r1.pdf" & @CRLF & _
"Obam_9781524763138_all_tcx10_r3 Folder/Links/001_apple_r1.pdf" & @CRLF & _
"Obam_9781524763138_all_tcx999_r3 Folder/Links/001_apple.pdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")