// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\u4e00-\u9fa5A-Za-z0-9\u3001-\u3003\uff1f\uff0c]+").unwrap();
let string = "测试";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}