$re = '/[\u4e00-\u9fa5A-Za-z0-9\u3001-\u3003\uff1f\uff0c]+/';
$str = '测试';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);