using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u4e00-\u9fa5A-Za-z0-9\u3001-\u3003\uff1f\uff0c]+";
string input = @"测试";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}