$re = '/^ *(?:@\w{1,15} *)+(?:ligne|bus|tram)? *(?<line>[a-zA-Z0-9][0-9]?)\b[\s\?]*$/i';
$str = '@Tag_Grenoble LIGNE C4 ???????';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);