const regex = /^ *(?:@\w{1,15} *)+(?:ligne|bus|tram)? *(?<line>[a-zA-Z0-9][0-9]?)\b[\s\?]*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *(?:@\\w{1,15} *)+(?:ligne|bus|tram)? *(?<line>[a-zA-Z0-9][0-9]?)\\b[\\s\\?]*$', 'i')
const str = `@Tag_Grenoble LIGNE C4 ???????`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}