import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *(?:@\\w{1,15} *)+(?:ligne|bus|tram)? *(?<line>[a-zA-Z0-9][0-9]?)\\b[\\s\\?]*$";
final String string = "@Tag_Grenoble LIGNE C4 ???????";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}