# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?ms)^\d+\.\s*(.*?)(?=^\d+\.|\Z)
"""
test_str = ("5. What ultrasound finding in a breast lesion is typically associated with malignancy?\n"
"A. Increased through transmission\n"
"B. Height greater than width\n"
"C. Hyperechogenicity\n"
"D. Surrounding hyperechoic halo\n"
"Key: B Rationale: A. Incorrect. Increased through transmission is typically associated with benign simple cysts. B. Correct. Height greater than width is a sonographic feature that is typically associated with malignancy. C. Incorrect. Hyperechogenicity typically is seen with benign fat containing lesions and is not a typical feature of malignancy. D. Incorrect. A surrounding hyperechoic (echogenic) halo is typically associated with benign post traumatic findings.\n"
"References: Stavros AT. Breast Ultrasound. Lippincott Williams and Wilkins, 2004. P. 472.\n\n"
"6. For which ONE of the following would a BIRADS 6 classification be MOST appropriate?\n"
"A. Post procedure mammogram for marker placement\n"
"B. Prior treated breast cancer\n"
"C. Recent biopsy proven breast cancer\n"
"D. Suspicious abnormality; needs biopsy\n"
"Key: C\n"
"Rationale: A. Incorrect. A Birads category is not given on the post procedure mammogram for marker placement. B. Incorrect. Patients with a history of breast cancer are not assigned a Birads Category 6, which is reserved for patients with known (untreated as yet) malignancy. C. Correct. Birads Category 6 is assigned to patients with a diagnosis of cancer who have not yet been definitively treated. D. Incorrect. Patients with suspicious abnormalities; need biopsy should be coded Birads Category 4. Birads 6 is reserved for patients with a known biopsy proven diagnosis of breast cancer.\n"
"References: ACR BIRADS Atlas, 5th Edition, 2013. P. 149-159.")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.