$re = '/(?ms)^\d+\.\s*(.*?)(?=^\d+\.|\Z)/xm';
$str = '5. What ultrasound finding in a breast lesion is typically associated with malignancy?
A. Increased through transmission
B. Height greater than width
C. Hyperechogenicity
D. Surrounding hyperechoic halo
Key: B Rationale: A. Incorrect. Increased through transmission is typically associated with benign simple cysts. B. Correct. Height greater than width is a sonographic feature that is typically associated with malignancy. C. Incorrect. Hyperechogenicity typically is seen with benign fat containing lesions and is not a typical feature of malignancy. D. Incorrect. A surrounding hyperechoic (echogenic) halo is typically associated with benign post traumatic findings.
References: Stavros AT. Breast Ultrasound. Lippincott Williams and Wilkins, 2004. P. 472.
6. For which ONE of the following would a BIRADS 6 classification be MOST appropriate?
A. Post procedure mammogram for marker placement
B. Prior treated breast cancer
C. Recent biopsy proven breast cancer
D. Suspicious abnormality; needs biopsy
Key: C
Rationale: A. Incorrect. A Birads category is not given on the post procedure mammogram for marker placement. B. Incorrect. Patients with a history of breast cancer are not assigned a Birads Category 6, which is reserved for patients with known (untreated as yet) malignancy. C. Correct. Birads Category 6 is assigned to patients with a diagnosis of cancer who have not yet been definitively treated. D. Incorrect. Patients with suspicious abnormalities; need biopsy should be coded Birads Category 4. Birads 6 is reserved for patients with a known biopsy proven diagnosis of breast cancer.
References: ACR BIRADS Atlas, 5th Edition, 2013. P. 149-159.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);