$re = '/^ *#define +([a-zA-Z][\w]*)\( *([a-zA-Z_]\w*)(?: *, *([a-zA-Z_]\w*) *) *\) *(.+) *$/m';
$str = ' #define AD9D9( _Xy_ , Y9_y3 ) x + y + 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);