package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *#define +([a-zA-Z][\w]*)\( *([a-zA-Z_]\w*)(?: *, *([a-zA-Z_]\w*) *) *\) *(.+) *$`)
var str = ` #define AD9D9( _Xy_ , Y9_y3 ) x + y + 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}