import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *#define +([a-zA-Z][\\w]*)\\( *([a-zA-Z_]\\w*)(?: *, *([a-zA-Z_]\\w*) *) *\\) *(.+) *$";
final String string = " #define AD9D9( _Xy_ , Y9_y3 ) x + y + 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}