$re = '/<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>/s';
$str = ' <p>{.lead} Prose is great.
</p>
<blockquote x="attr">
<p>{.quoted .para}A <strong>danger</strong>ous blockquote.</p>
</blockquote>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);