using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>";
string input = @" <p>{.lead} Prose is great.
</p>
<blockquote x=""attr"">
<p>{.quoted .para}A <strong>danger</strong>ous blockquote.</p>
</blockquote>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}