import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z\\-]+)>\\{([ \\w\\.-]+)\\} *(.*?)<\\/\\1>";
final String string = " <p>{.lead} Prose is great.\n"
+ "</p>\n\n"
+ "<blockquote x=\"attr\">\n"
+ " <p>{.quoted .para}A <strong>danger</strong>ous blockquote.</p>\n"
+ "</blockquote>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}