import Foundation
let pattern = #"(?<=">)(.*)(?=<)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<a href="http://upstore.net/vznxph8/(C87)_HJUKISM_(Hikoma_Hiroyuki)_Kuroe-chan_no_Iru_Omise_Chloe_Works_There_(Fate_kaleid_liner_Prisma_Illya)_English_=LWB=.zip">(C87)_HJUKISM_(Hikoma_Hiroyuki)_Kuroe-chan_no_Iru_Omise_Chloe_Works_There_(Fate_kaleid_liner_Prisma_Illya)_English_=LWB=.zip</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)