const regex = /(?<=">)(.*)(?=<)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=">)(.*)(?=<)', 'g')
const str = `<a href="http://upstore.net/vznxph8/(C87)_HJUKISM_(Hikoma_Hiroyuki)_Kuroe-chan_no_Iru_Omise_Chloe_Works_There_(Fate_kaleid_liner_Prisma_Illya)_English_=LWB=.zip">(C87)_HJUKISM_(Hikoma_Hiroyuki)_Kuroe-chan_no_Iru_Omise_Chloe_Works_There_(Fate_kaleid_liner_Prisma_Illya)_English_=LWB=.zip</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}