re = /(?P<cometes>[\'\"])(.*?)(?P=cometes)$/m
str = '\' "pep = 12" as\'
\' "pep = 12" \'
test "" \'pep "= 12\' "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end