package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<cometes>[\'\"])(.*?)(?P=cometes)$`)
var str = `' "pep = 12" as'
' "pep = 12" '
test "" 'pep "= 12' "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}