$re = '/(?P<cometes>[\'\"])(.*?)(?P=cometes)$/m';
$str = '\' "pep = 12" as\'
\' "pep = 12" \'
test "" \'pep "= 12\' "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);