const regex = new RegExp('((?<!t\\. | § |tz |h. )\\b[0-9][a-z]?\\b(?!A))', 'gm')
const str = `Art. 19 Cst.
§ 39 VG
§ 39 Abs. 1 und 2 VG
Art. 19 BV
Art. 62 Abs. 1 BV
Art. 3 BV
Art. 62 Abs. 2 BV
Art. 19 und 62 BV
Art. 13 UNO-Pakt I
Art. 28 KRK
Art. 19 BV
Art. 62 BV
Art. 62 BV
Art. 62 BV
Art. 62 BV
Art. 27 BV
Art. 14 KV/ZH
Art. 19 BV
Art. 19 BV
Art. 116 KV/ZH
Art. 27 BV
Art. 62 BV
Art. 62 BV
Art. 62 BV
Art. 62 BV
Art. 19 BV
Art. 36 BV
§ 39 Abs. 1 VG
§ 39a Abs. 1 VG
§ 39 Abs. 1a VG
§ 39 Abs. 1 VG
§ 39 VG
§ 39 Abs. 2 VG
Art. 302 Abs. 1 ZGB
§ 39 Abs. 2 Satz 1 VG
Art. 19 BV
Art. 8 Abs. 1 und 2 BV
Art. 19 und Art. 62 Abs. 2 BV
§ 39 Abs. 1 und 2 VG
Art. 18 BV
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}