#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<!t\. | § |tz |h. )\b[0-9][a-z]?\b(?!A))"
Local $sString = "Art. 19 Cst." & @CRLF & _
"§ 39 VG" & @CRLF & _
"§ 39 Abs. 1 und 2 VG" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 62 Abs. 1 BV" & @CRLF & _
"Art. 3 BV" & @CRLF & _
"Art. 62 Abs. 2 BV" & @CRLF & _
"Art. 19 und 62 BV" & @CRLF & _
"Art. 13 UNO-Pakt I" & @CRLF & _
"Art. 28 KRK" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 27 BV" & @CRLF & _
"Art. 14 KV/ZH" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 116 KV/ZH" & @CRLF & _
"Art. 27 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 62 BV" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 36 BV" & @CRLF & _
"§ 39 Abs. 1 VG" & @CRLF & _
"§ 39a Abs. 1 VG" & @CRLF & _
"§ 39 Abs. 1a VG" & @CRLF & _
"§ 39 Abs. 1 VG" & @CRLF & _
"§ 39 VG" & @CRLF & _
"§ 39 Abs. 2 VG" & @CRLF & _
"Art. 302 Abs. 1 ZGB" & @CRLF & _
"§ 39 Abs. 2 Satz 1 VG" & @CRLF & _
"Art. 19 BV" & @CRLF & _
"Art. 8 Abs. 1 und 2 BV" & @CRLF & _
"Art. 19 und Art. 62 Abs. 2 BV" & @CRLF & _
"§ 39 Abs. 1 und 2 VG" & @CRLF & _
"Art. 18 BV" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")