import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!t\\. | § |tz |h. )\\b[0-9][a-z]?\\b(?!A))";
final String string = "Art. 19 Cst.\n"
+ "§ 39 VG\n"
+ "§ 39 Abs. 1 und 2 VG\n"
+ "Art. 19 BV\n"
+ "Art. 62 Abs. 1 BV\n"
+ "Art. 3 BV\n"
+ "Art. 62 Abs. 2 BV\n"
+ "Art. 19 und 62 BV\n"
+ "Art. 13 UNO-Pakt I\n"
+ "Art. 28 KRK\n"
+ "Art. 19 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 27 BV\n"
+ "Art. 14 KV/ZH\n"
+ "Art. 19 BV\n"
+ "Art. 19 BV\n"
+ "Art. 116 KV/ZH\n"
+ "Art. 27 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 62 BV\n"
+ "Art. 19 BV\n"
+ "Art. 36 BV\n"
+ "§ 39 Abs. 1 VG\n"
+ "§ 39a Abs. 1 VG\n"
+ "§ 39 Abs. 1a VG\n"
+ "§ 39 Abs. 1 VG\n"
+ "§ 39 VG\n"
+ "§ 39 Abs. 2 VG\n"
+ "Art. 302 Abs. 1 ZGB\n"
+ "§ 39 Abs. 2 Satz 1 VG\n"
+ "Art. 19 BV\n"
+ "Art. 8 Abs. 1 und 2 BV\n"
+ "Art. 19 und Art. 62 Abs. 2 BV\n"
+ "§ 39 Abs. 1 und 2 VG\n"
+ "Art. 18 BV\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}