// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$").unwrap();
let string = "release/0.8
release/58.11
release/58.15.45
feature/VECTWO-1234-Something-Here
release/RC-0.8
release/58
feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}