import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((feature|bugfix|hotfix)\\/([a-zA-Z]{2,6}-\\d{1,6}|NO-?JIRA)\\-[a-zA-Z0-9-_]{1,30}|release\\/\\d+\\.\\d+\\.?\\d*)$";
final String string = "release/0.8\n"
+ "release/58.11\n"
+ "release/58.15.45\n"
+ "feature/VECTWO-1234-Something-Here\n\n"
+ "release/RC-0.8\n"
+ "release/58\n"
+ "feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}