re = /^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$/m
str = 'release/0.8
release/58.11
release/58.15.45
feature/VECTWO-1234-Something-Here
release/RC-0.8
release/58
feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end