// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Session (Start|Close): (\w{3} \w{3} \d{2} \d{2}:\d{2}:\d{2} \d{4})").unwrap();
let string = "Session Close: Fri Oct 30 21:35:44 1998
Session Start: Fri Oct 30 21:39:05 1998
*** Now talking in #östersund
Session Close: Fri Oct 30 21:40:48 1998
Session Start: Fri Oct 30 21:41:02 1998
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}