import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Session (Start|Close): (\\w{3} \\w{3} \\d{2} \\d{2}:\\d{2}:\\d{2} \\d{4})";
final String string = "Session Close: Fri Oct 30 21:35:44 1998\n\n"
+ "Session Start: Fri Oct 30 21:39:05 1998\n"
+ "*** Now talking in #östersund\n"
+ "Session Close: Fri Oct 30 21:40:48 1998\n\n"
+ "Session Start: Fri Oct 30 21:41:02 1998\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}