const regex = new RegExp('Session (Start|Close): (\\w{3} \\w{3} \\d{2} \\d{2}:\\d{2}:\\d{2} \\d{4})', 'gm')
const str = `Session Close: Fri Oct 30 21:35:44 1998
Session Start: Fri Oct 30 21:39:05 1998
*** Now talking in #östersund
Session Close: Fri Oct 30 21:40:48 1998
Session Start: Fri Oct 30 21:41:02 1998
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}