$re = '/^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$/m';
$str = 'GMT+05:30
GMT+5:30
GMT+04:60
GMT+13:50
GMT+00:30
GMT+12:56
GMT+11:59
GMT+12:00
GMT-11:00
GMT+5.30
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);