using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$";
string input = @"GMT+05:30
GMT+5:30
GMT+04:60
GMT+13:50
GMT+00:30
GMT+12:56
GMT+11:59
GMT+12:00
GMT-11:00
GMT+5.30
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}