#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$"
Local $sString = "GMT+05:30" & @CRLF & _
"GMT+5:30" & @CRLF & _
"GMT+04:60" & @CRLF & _
"GMT+13:50" & @CRLF & _
"GMT+00:30" & @CRLF & _
"GMT+12:56" & @CRLF & _
"GMT+11:59" & @CRLF & _
"GMT+12:00" & @CRLF & _
"GMT-11:00" & @CRLF & _
"GMT+5.30" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")